<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" prefix="og: http://ogp.me/ns#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>openSUSE Tumbleweed: a Linux Distro review | Tim Adams</title>
<link rel="pingback" href="http://transitophile.com/chango/xmlrpc.php" />

<!-- This site is optimized with the Yoast SEO plugin v7.8 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://transitophile.com/chango/opensuse-tumbleweed-a-linux-distro-review/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="openSUSE Tumbleweed: a Linux Distro review | Tim Adams" />
<meta property="og:description" content="I chronicled my Windows-to-Linux transition in early 2016, posted a mid-2017 update, today describe adoption of a new-to-me Linux variant. Two warnings! This post is: (&#x2666;) Inexcusably geeky. Inexcusably! I had something to say in 2016 and 2017, today only wallow shamelessly in a long-dormant computer nerd&#8217;s streak rekindled by the switch from Windows. Other &hellip;" />
<meta property="og:url" content="http://transitophile.com/chango/opensuse-tumbleweed-a-linux-distro-review/" />
<meta property="og:site_name" content="Tim Adams" />
<meta property="article:section" content="Linux" />
<meta property="article:published_time" content="2018-07-14T12:01:28+02:00" />
<meta property="article:modified_time" content="2018-07-14T12:36:34+02:00" />
<meta property="og:updated_time" content="2018-07-14T12:36:34+02:00" />
<meta property="og:image" content="http://transitophile.com/chango/wp-content/uploads/2018/07/alex_yellow.jpg" />
<meta property="og:image:width" content="397" />
<meta property="og:image:height" content="500" />
<meta property="og:image:alt" content="openSUSE Linux gecko | CC-BY-SA 3.0, https://github.com/openSUSE/artwork/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="I chronicled my Windows-to-Linux transition in early 2016, posted a mid-2017 update, today describe adoption of a new-to-me Linux variant. Two warnings! This post is: (&#x2666;) Inexcusably geeky. Inexcusably! I had something to say in 2016 and 2017, today only wallow shamelessly in a long-dormant computer nerd&#8217;s streak rekindled by the switch from Windows. Other [&hellip;]" />
<meta name="twitter:title" content="openSUSE Tumbleweed: a Linux Distro review | Tim Adams" />
<meta name="twitter:image" content="http://transitophile.com/chango/wp-content/uploads/2018/07/alex_yellow.jpg" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Person","url":"http:\/\/transitophile.com\/chango\/","sameAs":[],"@id":"#person","name":"Tim Adams"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Tim Adams &raquo; Feed" href="http://transitophile.com/chango/feed/" />
<link rel="alternate" type="application/rss+xml" title="Tim Adams &raquo; Comments Feed" href="http://transitophile.com/chango/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Tim Adams &raquo; openSUSE Tumbleweed: a Linux Distro review Comments Feed" href="http://transitophile.com/chango/opensuse-tumbleweed-a-linux-distro-review/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.0.9 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-42915454-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-42915454-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/transitophile.com\/chango\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='thematic_style-css'  href='http://transitophile.com/chango/wp-content/themes/thematic/style.css?ver=4.9.7' type='text/css' media='all' />
<script type='text/javascript' src='http://transitophile.com/chango/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://transitophile.com/chango/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://transitophile.com/chango/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.15'></script>
<link rel='https://api.w.org/' href='http://transitophile.com/chango/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://transitophile.com/chango/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://transitophile.com/chango/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://transitophile.com/chango/?p=1218' />
<link rel="alternate" type="application/json+oembed" href="http://transitophile.com/chango/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftransitophile.com%2Fchango%2Fopensuse-tumbleweed-a-linux-distro-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://transitophile.com/chango/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftransitophile.com%2Fchango%2Fopensuse-tumbleweed-a-linux-distro-review%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//transitophile.com/chango/?wordfence_lh=1&hid=ECD197DD4CE1A361FC771445BF502053');
</script>		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		</head>

<body class="post-template-default single single-post postid-1218 single-format-standard unknown-os unknown-browser">

	<div id="wrapper" class="hfeed">

		<div id="header">

        		<div id="branding">
    
    	<div id="blog-title"><span><a href="http://transitophile.com/chango/" title="Tim Adams" rel="home">Tim Adams</a></span></div>
    
    	<div id="blog-description">© 2011-2018</div>

		</div><!--  #branding -->
    
    <div id="access">
    
    	<div class="skip-link"><a href="#content" title="Skip navigation to the content">Skip to content</a></div><!-- .skip-link -->
    	
    	<div class="menu"><ul class="sf-menu"><li class="page_item page-item-46"><a href="http://transitophile.com/chango/about-me/">About Me</a></li></ul></div>    	
    </div><!-- #access -->
           		
    	</div><!-- #header-->		        
    	    	
	<div id="main">

		<div id="container">
			
			<div id="content">

				<div id="nav-above" class="navigation">
				
					<div class="nav-previous"><a href="http://transitophile.com/chango/mugged-in-guatemala-city/" rel="prev"><span class="meta-nav">&laquo;</span> Mugged in Guatemala City</a></div>
					
					<div class="nav-next"></div>
					
				</div>
					
				<div id="post-1218" class="post-1218 post type-post status-publish format-standard hentry category-linux" > 

				

					<h1 class="entry-title">openSUSE Tumbleweed: a Linux Distro review</h1>

					<div class="entry-meta">

	<span class="meta-prep meta-prep-author">By </span><span class="author vcard"><a class="url fn n" href="http://transitophile.com/chango/author/tim-adams/" title="View all posts by Tim Adams">Tim Adams</a></span>

	<span class="meta-sep meta-sep-entry-date"> | </span>

	<span class="meta-prep meta-prep-entry-date">Published: </span><span class="entry-date"><abbr class="published" title="2018-07-14T12:01:28+0200">July 14, 2018</abbr></span>

	

</div><!-- .entry-meta -->
     				
					<div class="entry-content">
					
						<p>I chronicled my Windows-to-Linux transition in early 2016, posted a mid-2017 update, today describe adoption of a new-to-me Linux variant.</p>
<p>Two warnings! This post is:</p>
<p>(<span style="color: #ff0000;">&#x2666;</span>) Inexcusably geeky. Inexcusably! I had something to say in <a href="http://transitophile.com/chango/one-more-linux-user/">2016</a> and <a href="http://transitophile.com/chango/more-than-a-year-with-linux/">2017</a>, today only wallow shamelessly in a long-dormant computer nerd&#8217;s streak rekindled by the switch from Windows.</p>
<p>Other geeks may read my ravings with interest. No one else will. I am not a computer writer, have no business pitching the blog 4&#215;4 into the bush for a wild-eyed hobbyist detour. No editor would accept this.</p>
<div id="attachment_1219" style="width: 407px" class="wp-caption aligncenter"><a href="http://transitophile.com/chango/wp-content/uploads/2018/07/alex_yellow.jpg"><img class="size-full wp-image-1219" src="http://transitophile.com/chango/wp-content/uploads/2018/07/alex_yellow.jpg" alt="openSUSE Linux gecko | CC-BY-SA 3.0, https://github.com/openSUSE/artwork/" width="397" height="500" srcset="http://transitophile.com/chango/wp-content/uploads/2018/07/alex_yellow.jpg 397w, http://transitophile.com/chango/wp-content/uploads/2018/07/alex_yellow-238x300.jpg 238w" sizes="(max-width: 397px) 100vw, 397px" /></a><p class="wp-caption-text">openSUSE Linux gecko | CC-BY-SA 3.0, https://github.com/openSUSE/artwork/</p></div>
<p>(<span style="color: #ff0000;">&#x2666;</span>) Potentially dangerous. Casual new Linux tinkerers should be shooed away <em>posthaste</em> from the variant to be described, may monkey wrench functional machinery, tempt rage, bankruptcy! madness! death!</p>
<p>Fellow nerds may be curious anyway. So were ancient Greek mariners, about those sweetly-crooning sirens in <a href="https://en.wikipedia.org/wiki/Odyssey">Odyssey</a>. Read on! You&#8217;ve been warned.</p>
<p style="text-align: center;">* * * * *</p>
<p>Since Windows NT begot Windows 2000 and Windows 2000 begot Windows XP, I have dreamed of freedom from the operating system release cycle. I understood the &#8220;why&#8221; of the release cycle. Software developers couldn&#8217;t kick powerful new features out the door willy-nilly; they had to test, tune, package, test again, fuss over scripts to transition clueless hunt-and-peckers from superseded Platform A to latest-and-greatest Platform B.</p>
<p>The &#8220;what&#8221; rankled. I didn&#8217;t want to buy another box, another license, a new disc, another bloated manual. As Windows matured, I bitterly suspected Redmond of issuing new editions largely to extort license fee income from defenseless users.</p>
<p>Might there be an alternative? What if I could install an OS once, only once, and thereafter let the binary thing nurture itself online; consume patches and upgrades as needed; sip, feed and excrete without regularly demanding new licenses, boxes and disks from weary ol&#8217; Tim? Did I dream idly? Might such an OS exist?</p>
<p>Not in the Windows world, and I saw no hope from Cupertino, either; MacOS users trudged from Lion to Yosemite to Sierra, as I had slogged from NT to XP to 7. Most free Linux &#8220;distros&#8221; also evolved via the release cycle model.</p>
<p>(Which should have told me plenty. A whole lot of plenty. I risk getting ahead of myself.)</p>
<p>But: the anarchic Linux world also offered a few tantalizing exceptions: &#8220;rolling release&#8221; distros. I read details of these hybrids, blinked, rubbed disbelieving eyes. My dream made real!</p>
<p>The user might install a &#8220;rolling release&#8221; distro once, only once. The OS could thereafter slurp limitlessly from an online fountain of youth, forever make itself fresh, current, up to date, whole. A rolling release is versionless.</p>
<p>Reddit contributors <a href="https://www.reddit.com/r/archlinux/comments/4ooxpk/what_is_the_longest_running_stable_installation/">claimed</a> that Arch Linux rollers installed in 2008 and 2010 still tickety-tocked smoothly in 2016. These did not limp along on patch-swaddled last legs, like an obsolete Windows install in the twilight of an extended support cycle. No: the 2008 Arch install had rejuvenated itself time and time again, could declare itself equal to an Arch install downloaded and configured this morning. It may continue to emit that new OS smell in 2025, 2030, beyond.</p>
<p>I studied, prowled Linux bulletin boards, identified rolling distros, compared. I could try Gentoo, which <a href="https://www.pcworld.com/article/238068/how_linux_mastered_wall_street.html">powers</a> Nasdaq (or did in 2011), but glimpsed signs of a fading <a href="https://www.infoworld.com/article/3109830/linux/why-did-gentoo-linux-fade-into-obscurity.html">star</a>. Arch is certainly the best known roller, but is notoriously opaque to newcomers, won&#8217;t install without mechanicking. Worse, for me: Arch seemed far more willing to frisbee bleeding edge software to users without adequate testing. Variants Antergos and Manjaro would be easier to use, but hadn&#8217;t been around that long, at least by my standards.</p>
<p>I turned to openSUSE <a href="https://www.opensuse.org/#Tumbleweed">Tumbleweed</a>. A <a href="https://rootco.de/2016-03-28-why-use-tumbleweed/">post</a> by openSUSE chair Richard Brown averred that Tumbleweed tested far more thoroughly than Arch or Gentoo, thanks to the Open Build Service. I contemplated praise from Linux writers <a href="https://www.zdnet.com/article/opensuse-tumbleweed-a-linux-distribution-on-the-leading-edge/">J.A. Watson</a> and <a href="https://www.cio.com/article/3008856/open-source-tools/is-opensuse-tumbleweed-good-enough-for-a-seasoned-arch-user.html">Swapnil Bhartiya</a>, judged the praise as credible. No less a light than Linux Foundation <a href="https://www.linuxfoundation.org/about/linux-foundation-fellows/">fellow</a> Greg Kroah-Hartman had conjured up the Tumbleweed model. How wrong could I go? And I felt like tinkering.</p>
<p>I bid adieu to the already-excellent Linux Mint distro, installed Tumbleweed in the summer of &#8217;17, write with my verdict a year later.</p>
<p>Do I like it?</p>
<p>I do! Very much! I hunt and peck these very words on a computer directed by Tumbleweed.</p>
<p>Should I have adopted it in the first place?</p>
<p>Probably not. openSUSE, sure. The Tumbleweed rolling distro, well &#8230;</p>
<p>Do I recommend it to most other users? To Linux newcomers?</p>
<p><strong><span style="color: #ff0000;">NO! NO! NO! NO!</span></strong></p>
<p><strong><span style="color: #ff0000;">NO! NO! NO! NO!</span></strong></p>
<p>Only to enthusiasts. If you enjoy computer configuration and can cope with inevitable related bumps and scrapes, join me as I plunge into the gory details:</p>
<p style="text-align: center;">* * * * *</p>
<p>The Tumbleweed distro is issued in snapshots. Subscribers to the online open-suse factory mailing <a href="https://lists.opensuse.org/opensuse-factory/">list</a> receive automated messages declaring issuance of snapshot 20180626, or 20181030, or, if all goes well, 20850105. Each snapshot incorporates whatever whiz-bang software cleared testing after the release of the predecessor snapshot days earlier.</p>
<p>Users may see seven snapshots in a week, or three, or, rarely, none. It depends. One may ignore their issuance, compute merrily along with a snapshot from months before, but may not always compute safely; the fresh snapshots also tend to security concerns.</p>
<p>How does one upgrade a snapshot? As I write in mid 2018: via one occult command, and one command only, issued from the root user terminal prompt:</p>
<pre style="text-align: center;"><strong>zypper dup</strong></pre>
<p>Will Tumbleweed harangue the new user to use this command, and this command only? No! Worse: the freshly-installed Tumbleweed OS is likely to include a cute icon in the system tray, brightly informing the clueless newbie that XX updates are available for download.</p>
<p>The newbie is supposed to <em><span style="color: #000000;"><strong>ignore</strong></span></em> this cute icon. (And may finally be abetted in this ignoring by a long overdue distro change, according to a recent <a href="https://forums.opensuse.org/showthread.php/531834-Software-Updates-widget-can-no-longer-install-packages-asks-user-to-run-zypper-dup-manually">post</a> on the support forum.) The icon would invoke changes afield of the sacroscant zypper dup, could monkey wrench Tumbleweed&#8217;s innards. He is just supposed to know that, as one knows how to squirm, lick lips, drool.</p>
<p>The user willing to overlook this idiosyncrasy shall greet an otherwise first rate, state-of-the-art Linux operating system. Eventually she shall want to invoke the almighty <em>zypper dup</em>, to see if anything has changed since installation.</p>
<p>Usually, something has. A lot of somethings. Rolling releases like Tumbleweed strive to offer the latest and greatest. If program author A tweaks two lines of code to issue version 0.97.6.7.5.3b of her pride and joy, superseding version 0.97.6.7.5.3a, you&#8217;re going to get it after it clears testing, whether you needed 0.97.6.7.5.3b or not.</p>
<p>I judged my old Linux Mint installation to be busy if it downloaded a half dozen patches in a day. A single <em>zypper dup</em> may announce availability of hundreds of new packages, editions, kernels, patches. If you&#8217;ve let the computer sit for a month, &#8216;hundreds&#8217; may swell to &#8216;thousands.&#8217;</p>
<p>Everything new, current, up-to-date. I run the latest and greatest Linux <a href="https://www.kernel.org/">kernel</a>, or close to it; the latest and greatest browsers, email clients, office suites, utilities. I don&#8217;t download programs from hither and yon, as in my Windows days; my software is tested, verified, hails straight from the openSUSE repositories. I compute more safely.</p>
<p>Tumbleweed feels zippy, polished, expert, tight, more so than Linux Mint, far more so than Windows 7. The above-mentioned repositories host most everything I could hope to install while using any Linux distro. I have escaped the release cycle, as I dreamed, and have done so aboard one of Linux&#8217;s most professional, respected distros.</p>
<p>What&#8217;s not to like?</p>
<p>Two negatives, one trivial, one not trivial at all.</p>
<p>(<span style="color: #ff0000;">&#x2666;</span>) <em>Zypper dup</em> can consume thirty minutes, even with an SSD.</p>
<p>And the potential deal breaker:</p>
<p>(<span style="color: #ff0000;">&#x2666;</span>) On five occasions since my summer-of-2017 adoption of Tumbleweed, <em>zypper dup</em> either Chernobyled my computer or rendered some essential program inoperable.</p>
<p>Get that, please, grok it; put it in your pipe, smoke it. Innocent, unsuspecting <em>moi</em> ran <em>zypper dup</em> to update like a good Tumbleweeder, as a Windows user would update on Patch Tuesday, and found myself afterward with an unusable machine. <em>Zypper dup</em> had blackjacked my box, without warning, through no fault of my own.</p>
<p>(The culprit in two of the five Chernobyls was Tumbleweed&#8217;s temperamental relationship with the proprietary Nvidia graphics card driver, warned about in the J.A. Watson article. I could have swapped cards, or used the open-source driver. The other three blow-ups had nothing to do with Nvidia.)</p>
<p>So life goes with a rolling distro. Self-reliance is presumed, a frontier spirit. New point releases are fine tuned, fretted about, fussed over, presented on sparkling silver cloche platters. Additions to rolling distros are heaved brusquely over transoms. No one forced me to compute alongside the experts who run rollers. They can fix the occasional mess made by a Tumbleweed or Arch update. I&#8217;m supposed to be able to fix it, too.</p>
<p>So far, I have managed. An update that KOs my computer invariably KOs others. The experts gripe, on the mailing list and in the openSUSE <a href="https://forums.opensuse.org/forum.php">forums</a>; they troubleshoot, offer tips, solutions. I keep <a href="https://clonezilla.org/">Clonezilla</a> disk image back-ups of my Tumbleweed installation, can fall back on an older snapshot until the problem is fixed.</p>
<p>The bittersweet result: I may be free of the operating system release cycle, but have spent far more time fussing over my rolling distro than I ever would have fussed to upgrade from point release A to point release B. openSUSE impresses, but I probably should have (sigh &#8230;) adopted their point release distro <a href="https://www.opensuse.org/#Leap">Leap</a> instead, or stood pat with <a href="https://www.linuxmint.com/">Mint</a>. (Although I&#8217;ll likely Tumble from here on in, now that I&#8217;ve hacked my way through the worst of the Tumbleweed learning curve.)</p>
<p>If also tempted by the Tumbleweed bleeding edge: Dost thou know how to make and restore a disk image, either via the fabulous free Clonezilla or a commercial equivalent? Canst thou partition a disk, and, perhaps, fix a broken boot loader? I&#8217;ll dare to name these skills as entry bars for Tumbleweed adoption, especially the first one. I figured out how to do this stuff, still judge my knowledge as barely adequate to drive Tumbleweed daily. (Although one can install the Tumbleweed ISO in a virtual machine, fiddle to one&#8217;s heart&#8217;s content.)</p>
<p style="text-align: center;">* * * * *</p>
<p>Mostly nerd-only notes:</p>
<p>(<span style="color: #ff0000;">&#x2666;</span>) I&#8217;ve got lots of ram, installed Tumbleweed without swap in a single ext4 partition, immediately disabled Snapper. Clonezilla likes ext4, hasn&#8217;t played well with the default btrfs file format.</p>
<p>(<span style="color: #ff0000;">&#x2666;</span>) I installed the Nvidia driver &#8220;the <a href="https://en.opensuse.org/SDB:NVIDIA_the_hard_way">hard way</a>,&#8221; was unimpressed by experiments with the Tumbleweed Nvidia repository and DKMS.</p>
<p>(<span style="color: #ff0000;">&#x2666;</span>) Expect freely-given expert advice in the user forums, a strong openSUSE plus.</p>
<p>(<span style="color: #ff0000;">&#x2666;</span>) Thank you, openSUSErs Simon Lees, Doug DeMaio, Jimmy Berry and unknown others, for graciously fielding my ignoramus questions at the annual <a href="https://events.opensuse.org/conference/oSC18">conference</a> this May in Prague.</p>
<p>(<span style="color: #ff0000;">&#x2666;</span>) Amiable openSUSE chair Richard Brown told me at this conference that Greg Kroah-Hartman gets credit for that fat <em>Weltschmerz</em> of a distro name: Tumbleweed. Think about it. It doesn&#8217;t roll; it tumbles, like a rusty TV clattering off the back of a dump truck. What opinion does its own inventor hold of that which tumbles? Did he call it a TumbleDiamond, or a TumbleBlossom? Success despite pessimism!</p>

												
					</div><!-- .entry-content -->
					
					<div class="entry-utility">

						<span class="cat-links">This entry was posted in <a href="http://transitophile.com/chango/category/linux/" rel="category tag">Linux</a></span>. Bookmark the <a title="Permalink to openSUSE Tumbleweed: a Linux Distro review" href="http://transitophile.com/chango/opensuse-tumbleweed-a-linux-distro-review/">permalink</a>. <a class="comment-link" title="Post a comment" href="#respond">Post a comment</a> or leave a trackback: <a class="trackback-link" href="http://transitophile.com/chango/opensuse-tumbleweed-a-linux-distro-review/trackback/" title ="Trackback URL for your post" rel="trackback">Trackback URL</a>.

					</div><!-- .entry-utility -->
					
				</div><!-- #post -->
		
			<div id="nav-below" class="navigation">
				<div class="nav-previous"><a href="http://transitophile.com/chango/mugged-in-guatemala-city/" rel="prev"><span class="meta-nav">&laquo;</span> Mugged in Guatemala City</a></div>
				<div class="nav-next"></div>
			</div>

								
				<div id="comments">
	
					
											
				<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Post a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/chango/opensuse-tumbleweed-a-linux-distro-review/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://transitophile.com/chango/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes">Your email is <em>never</em> published nor shared. Required fields are marked <span class="required">*</span></p><div id="form-section-comment" class="form-section"><div class="form-label"><label for="comment">Comment</label></div><div class="form-textarea"><textarea id="comment" name="comment" cols="45" rows="8" tabindex="6" aria-required="true"></textarea></div></div><!-- #form-section-comment .form-section --><div id="form-allowed-tags" class="form-section"><p><span>You may use these <abbr title="HyperText Markup Language">HTML</abbr> tags and attributes</span> <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></p></div><div id="form-section-author" class="form-section"><div class="form-label"><label for="author">Name</label> <span class="required">*</span></div><div class="form-input"><input id="author" name="author" type="text" value="" size="30" maxlength="20" tabindex="3" aria-required='true' /></div></div><!-- #form-section-author .form-section -->
<div id="form-section-email" class="form-section"><div class="form-label"><label for="email">Email</label> <span class="required">*</span></div><div class="form-input"><input id="email" name="email" type="email" value="" size="30" maxlength="50" tabindex="4" aria-required='true' /></div></div><!-- #form-section-email .form-section -->
<div id="form-section-url" class="form-section"><div class="form-label"><label for="url">Website</label></div><div class="form-input"><input id="url" name="url" type="url" value="" size="30" maxlength="50" tabindex="5" /></div></div><!-- #form-section-url .form-section -->
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1218' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="633f0319b1" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="184"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>	
				</div><!-- #comments -->
				
						
			</div><!-- #content -->
			
			 
		</div><!-- #container -->
		

		<div id="primary" class="aside main-aside">

			<ul class="xoxo">

				<li id="search-2" class="widgetcontainer widget_search"><h3 class="widgettitle"><label for="s">Search</label></h3>

						<form id="searchform" method="get" action="http://transitophile.com/chango/">

							<div>
								<input id="s" name="s" type="text" value="To search, type and hit enter" onfocus="if (this.value == 'To search, type and hit enter') {this.value = '';}" onblur="if (this.value == '') {this.value = 'To search, type and hit enter';}" size="32" tabindex="1" />

								<input id="searchsubmit" name="searchsubmit" type="submit" value="Search" tabindex="2" />
							</div>

						</form>

					</li>		<li id="recent-posts-2" class="widgetcontainer widget_recent_entries">		<h3 class="widgettitle">Recent Posts</h3>
		<ul>
											<li>
					<a href="http://transitophile.com/chango/opensuse-tumbleweed-a-linux-distro-review/">openSUSE Tumbleweed: a Linux Distro review</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/mugged-in-guatemala-city/">Mugged in Guatemala City</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/usa-in-the-rear-view/">USA in the Rear View</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/eeuu-en-el-espejo-retrovisor/">EEUU en el Espejo Retrovisor</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/madrid-impressions-round-five/">Madrid Impressions: Round Five</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/polyglot-tips-n-tricks/">Polyglot Tips N&#8217; Tricks</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/catalonia-cautiously-contemplated/">Catalonia Cautiously Contemplated</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/how-i-renewed-my-spain-visa/">How I Renewed my Spain Visa</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/madrid-impressions-round-four/">Madrid Impressions: Round Four</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/bucharest-first-impressions/">Bucharest: First Impressions</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/rail-day-trips-from-madrid/">Rail Day Trips from Madrid</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/explaining-the-american-accent/">Explaining the American Accent</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/more-than-a-year-with-linux/">More than a Year with Linux</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/madrid-impressions-round-three/">Madrid Impressions: Round Three</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/spain-expat-odds-and-ends/">Spain Expat Odds and Ends</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/i-introduce-madrid-cercanias-commuter-rail/">I introduce Madrid Cercanías commuter rail</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/conversations-with-techies/">Conversations with Techies</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/spanish-as-spoken-in-spain/">Spanish as Spoken in Spain</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/for-expats-an-international-move/">For Expats: an International Move</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/for-expats-renting-a-madrid-apartment/">For Expats: Renting a Madrid Apartment</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/usa-to-spain-going-expat/">USA to Spain: Going Expat</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/i-explain-trump-to-spain/">I Explain Trump to Spain</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/alecciono-a-espana-sobre-trump/">Alecciono a España sobre Trump</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/madrid-second-impressions/">Madrid: Second Impressions</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/gear-for-long-haul-travel/">Gear for Long-Haul Travel</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/tracy-california-first-impressions/">Tracy, California: First Impressions</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/marrakech-first-impressions/">Marrakech: First Impressions</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/one-more-linux-user/">One More Linux User</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/budapest-first-impressions/">Budapest: First Impressions</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/unenthusiastic-about-marijuana/">Unenthusiastic About Marijuana</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/istanbul-first-impressions/">Istanbul: First Impressions</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/scouting-honest-reviews-online/">Scouting Honest Reviews Online</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/tale-of-three-prepaid-local-sim-cards/">Tale of Three Prepaid Local SIM Cards</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/god-of-mission-street/">The God of Mission Street</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/home-coffee-roasting-a-new-hobby/">Home Coffee Roasting: A New Hobby</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/transit-vs-car-a-few-conclusions/">Transit vs  Car: a Few Conclusions</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/tips-for-new-or-rusty-travelers/">Tips for New or Rusty Travelers</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/athens-rome-barcelona/">Athens, Rome, Barcelona</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/dubai-first-impressions/">Dubai: First Impressions</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/made-the-law-made-a-loophole/">Made the Law, Made a Loophole</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/better-marks-for-muni/">Better Marks for Muni</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/still-more-european-odds-and-ends/">Still More European Odds and Ends</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/biking-in-amsterdam/">Biking in Amsterdam</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/european-odds-and-ends/">European Odds and Ends</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/how-i-get-around/">How I Get Around</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/zurich-and-copenhagen/">Zurich and Copenhagen</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/about-those-transit-gulags/">About those transit gulags</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/more-about-moscow/">More about Moscow &#8230;</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/moscow-metro-guide-for-english-speakers/">Moscow Metro guide for English speakers</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/tokyo-seoul-shanghai/">Tokyo, Seoul, Shanghai</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/travels-deeply-south/">Travels Deeply South</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/sign-hill-park/">Sign Hill Park</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/travels-northwest/">Travels Northwest</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/transit-riding-tips-at-random/">Transit riding tips at random</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/san-bruno-mountain-state-park/">San Bruno Mountain State Park</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/graffiti-on-the-14-bus/">Graffiti on the 14 bus</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/remembering-lee-joseph/">Remembering Lee Joseph</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/a-job-like-hmf/">A Job like HM&#038;F</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/back-to-transitophile-4/">Back to Transitophile &#8230;</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/mechanicking-memories/">Mechanicking Memories</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/a-photo-of-ruby-the-good-luck-dog/">A photo of Ruby, the good luck dog</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/why-i-wrote-brothers-of-the-milky-way-2/">Why I wrote Brothers of the Milky Way</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/hello-world-2/">Posts from TransitoPhile blog &#8230;</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/a-los-angeles-straphanger-in-toronto-and-montreal/">A Los Angeles straphanger in Toronto and Montreal</a>
									</li>
											<li>
					<a href="http://transitophile.com/chango/public-transit-in-l-a-an-older-but-wiser-look-back/">Public Transit in L.A.: an older-but-wiser look back</a>
									</li>
					</ul>
		</li><li id="recent-comments-2" class="widgetcontainer widget_recent_comments"><h3 class="widgettitle">Recent Comments</h3>
<ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">George Matiasz</span> on <a href="http://transitophile.com/chango/about-me/#comment-53762">About Me</a></li><li class="recentcomments"><span class="comment-author-link">Tim Adams</span> on <a href="http://transitophile.com/chango/for-expats-renting-a-madrid-apartment/#comment-52489">For Expats: Renting a Madrid Apartment</a></li><li class="recentcomments"><span class="comment-author-link">Jill</span> on <a href="http://transitophile.com/chango/for-expats-renting-a-madrid-apartment/#comment-52478">For Expats: Renting a Madrid Apartment</a></li><li class="recentcomments"><span class="comment-author-link">Tim Adams</span> on <a href="http://transitophile.com/chango/i-explain-trump-to-spain/#comment-51524">I Explain Trump to Spain</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://spainresidency.com/' rel='external nofollow' class='url'>Kristian Zwart</a></span> on <a href="http://transitophile.com/chango/i-explain-trump-to-spain/#comment-51468">I Explain Trump to Spain</a></li></ul></li><li id="rss-links-3" class="widgetcontainer widget_rss-links"><h3 class="widgettitle">RSS Links</h3>
			<ul>
				<li><a href="http://transitophile.com/chango/feed/" title="Tim Adams Posts RSS feed" rel="alternate nofollow" type="application/rss+xml">All posts</a></li>
				<li><a href="http://transitophile.com/chango/comments/feed/" title="Tim Adams Comments RSS feed" rel="alternate nofollow" type="application/rss+xml">All comments</a></li>
			</ul>
</li><li id="archives-2" class="widgetcontainer widget_archive"><h3 class="widgettitle">Archives</h3>
		<ul>
			<li><a href='http://transitophile.com/chango/2018/07/'>July 2018</a></li>
	<li><a href='http://transitophile.com/chango/2018/06/'>June 2018</a></li>
	<li><a href='http://transitophile.com/chango/2018/04/'>April 2018</a></li>
	<li><a href='http://transitophile.com/chango/2018/03/'>March 2018</a></li>
	<li><a href='http://transitophile.com/chango/2018/01/'>January 2018</a></li>
	<li><a href='http://transitophile.com/chango/2017/11/'>November 2017</a></li>
	<li><a href='http://transitophile.com/chango/2017/08/'>August 2017</a></li>
	<li><a href='http://transitophile.com/chango/2017/07/'>July 2017</a></li>
	<li><a href='http://transitophile.com/chango/2017/06/'>June 2017</a></li>
	<li><a href='http://transitophile.com/chango/2017/05/'>May 2017</a></li>
	<li><a href='http://transitophile.com/chango/2017/02/'>February 2017</a></li>
	<li><a href='http://transitophile.com/chango/2017/01/'>January 2017</a></li>
	<li><a href='http://transitophile.com/chango/2016/12/'>December 2016</a></li>
	<li><a href='http://transitophile.com/chango/2016/11/'>November 2016</a></li>
	<li><a href='http://transitophile.com/chango/2016/09/'>September 2016</a></li>
	<li><a href='http://transitophile.com/chango/2016/08/'>August 2016</a></li>
	<li><a href='http://transitophile.com/chango/2016/07/'>July 2016</a></li>
	<li><a href='http://transitophile.com/chango/2016/06/'>June 2016</a></li>
	<li><a href='http://transitophile.com/chango/2016/01/'>January 2016</a></li>
	<li><a href='http://transitophile.com/chango/2015/12/'>December 2015</a></li>
	<li><a href='http://transitophile.com/chango/2015/06/'>June 2015</a></li>
	<li><a href='http://transitophile.com/chango/2015/05/'>May 2015</a></li>
	<li><a href='http://transitophile.com/chango/2015/02/'>February 2015</a></li>
	<li><a href='http://transitophile.com/chango/2015/01/'>January 2015</a></li>
	<li><a href='http://transitophile.com/chango/2014/11/'>November 2014</a></li>
	<li><a href='http://transitophile.com/chango/2014/10/'>October 2014</a></li>
	<li><a href='http://transitophile.com/chango/2014/06/'>June 2014</a></li>
	<li><a href='http://transitophile.com/chango/2014/05/'>May 2014</a></li>
	<li><a href='http://transitophile.com/chango/2014/03/'>March 2014</a></li>
	<li><a href='http://transitophile.com/chango/2014/02/'>February 2014</a></li>
	<li><a href='http://transitophile.com/chango/2013/12/'>December 2013</a></li>
	<li><a href='http://transitophile.com/chango/2013/10/'>October 2013</a></li>
	<li><a href='http://transitophile.com/chango/2013/09/'>September 2013</a></li>
	<li><a href='http://transitophile.com/chango/2013/08/'>August 2013</a></li>
	<li><a href='http://transitophile.com/chango/2013/07/'>July 2013</a></li>
	<li><a href='http://transitophile.com/chango/2011/10/'>October 2011</a></li>
		</ul>
		</li><li id="categories-2" class="widgetcontainer widget_categories"><h3 class="widgettitle">Categories</h3>
		<ul>
	<li class="cat-item cat-item-50"><a href="http://transitophile.com/chango/category/asia/" >Asia</a>
</li>
	<li class="cat-item cat-item-2"><a href="http://transitophile.com/chango/category/brothers-of-the-milky-way/" >Brothers of the Milky Way</a>
</li>
	<li class="cat-item cat-item-66"><a href="http://transitophile.com/chango/category/coffee/" >Coffee</a>
</li>
	<li class="cat-item cat-item-53"><a href="http://transitophile.com/chango/category/europe/" >Europe</a>
</li>
	<li class="cat-item cat-item-85"><a href="http://transitophile.com/chango/category/expat/" >Expat</a>
</li>
	<li class="cat-item cat-item-96"><a href="http://transitophile.com/chango/category/language/" >language</a>
</li>
	<li class="cat-item cat-item-92"><a href="http://transitophile.com/chango/category/linux/" >Linux</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://transitophile.com/chango/category/los-angeles-mta-mass-public-transit-environmentalism-red-line-purple-line-blue-line-green-line/" >Los Angeles MTA mass public transit environmentalism Red Line Purple Line Blue Line Green Line</a>
</li>
	<li class="cat-item cat-item-84"><a href="http://transitophile.com/chango/category/madrid/" >Madrid</a>
</li>
	<li class="cat-item cat-item-22"><a href="http://transitophile.com/chango/category/san-francisco/" >San Francisco</a>
</li>
	<li class="cat-item cat-item-97"><a href="http://transitophile.com/chango/category/spanish/" >Spanish</a>
</li>
	<li class="cat-item cat-item-89"><a href="http://transitophile.com/chango/category/transit/" >Transit</a>
</li>
	<li class="cat-item cat-item-61"><a href="http://transitophile.com/chango/category/travel/" >Travel</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://transitophile.com/chango/category/uncategorized/" >Uncategorized</a>
</li>
		</ul>
</li><li id="meta-2" class="widgetcontainer widget_meta"><h3 class="widgettitle">Meta</h3>
			<ul>
						<li><a rel="nofollow" href="http://transitophile.com/chango/wp-login.php">Log in</a></li>
						</ul>
</li>
				</ul>

		</div><!-- #primary .aside -->

				
		</div><!-- #main -->
    	
    	<div id="footer">	
        	
        	    
	<div id="siteinfo">        

   			Powered by <a class="wp-link" href="http://WordPress.org/" title="WordPress" rel="generator">WordPress</a>. Built on the <a class="theme-link" href="http://thematictheme.com" title="Thematic Theme Framework" rel="home">Thematic Theme Framework</a>.

	</div><!-- #siteinfo -->
	
   	        	
		</div><!-- #footer -->
    	
	</div><!-- #wrapper .hfeed -->
<script type='text/javascript' src='http://transitophile.com/chango/wp-includes/js/comment-reply.min.js?ver=4.9.7'></script>
<script type='text/javascript' src='http://transitophile.com/chango/wp-includes/js/hoverIntent.js?ver=4.9.7'></script>
<script type='text/javascript' src='http://transitophile.com/chango/wp-content/themes/thematic/library/scripts/superfish.js?ver=1.4.8'></script>
<script type='text/javascript' src='http://transitophile.com/chango/wp-content/themes/thematic/library/scripts/supersubs.js?ver=0.2b'></script>
<script type='text/javascript' src='http://transitophile.com/chango/wp-content/themes/thematic/library/scripts/thematic-dropdowns.js?ver=1.0'></script>
<script type='text/javascript' src='http://transitophile.com/chango/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<script async="async" type='text/javascript' src='http://transitophile.com/chango/wp-content/plugins/akismet/_inc/form.js?ver=4.0.8'></script>

</body>
</html>